Install UQLab on server

I would like to install UQLab on the Matlab that I use on my laboratory cluster (so I don’t have full root access). I got the license and the UQLab files folder.
I am aware of this thread Install UQLab without write access to matlabroot, so I tried in my local working directory
create a folder mymatlab
In Matlab in

Preferences->General->Initial Working Folder

I set /home/dmetivie/mymatlab as my Initial working folder.
create an empty file pathdefin mymatlab folder
then in UQLabCore_Rel1.3.0/core/
when I run uqlab_install I get

No available license for the optimization toolbox and for the global optimization toolbox
Warning: Some features of the software may not be available 
> In uqlab_install 
Warning: the UQLab installer detected that the MATLAB path could not be saved.
Please make sure that the MATLAB startup folder is set to a writable location in the MATLAB preferences:
Preferences->General->Initial Working Folder

Checking for updates...
The installation was not successful!
The installer returned the following message: Error downloading URL. Your network connection may be down or your proxy settings improperly configured.

Do you know what I am doing wrong?

Hello @dmetivie,

About the error you get: could you please try executing the following command within Matlab


and let us know about the result you get?

7 posts were split to a new topic: Loading UQLab on a cluster

Dear Christos,
I’m up against same problem as Dmetivie, when I tried top install UQLAB in a commericial HPC.
The Following are the message I got:

And when I input: urlread(‘https://uqlicense.ethz.ch/verify_access/’) , I got following messages.QQ图片20210126200401

Dear all,
The problem is not on the UQLab side: please contact your server admins and show them the message.

The DNS can’t resolve the address of uqftp.ethz.ch . This is a network configuration issue (are the servers airtight, i.e. not directly connected to the internet?).

UQLab requires a live internet connection, in particular outwards connectivity to port 443 (https) of both uqlicense.ethz.ch (licensing) and uqftp.ethz.ch (updating).

If you still have issues, please contact us at uqlab@ethz.ch for support.

Take care

Thanks Stefano,
It’s great, I have solved this problem!
Zhipeng Lai

1 Like