Dear @paulremo, dear all,
you/Paul-Remo Wagner wrote in one of your/his posts dealing with the contents of
While reviewing this, I realized that the naming of
PostPred) is not ideal. In the next version of the module, these names will therefore be updated. For
.PriorPredSampleI suggest the field names
Concerning this planed renaming of the contents of
.PostPredSample, I think that it may create confusion if in the UQLab code the name
.....Results.PriorPredSample.Sample is used for the model output with noise and
....Results.sample is still the name for the samples resulting form the MCMC sampler.
This holds at least for those persons, who are now used to the fact that the only data object denoted as
.sample are the samples for the parameter (and discrepancy) values from the MCMC sampling in
....Results, while the names of all other data object containing samples either start with some prefix information on the considered object followed by
sample or do not contain the substring
sample at all.
Being not afraid of using long names, I would like to suggest to use
.ModelEvalWithNoise or .
.ModelEval) to replace
Post), respectively. But maybe someone has a better idea.