Error installing uqlab in MATLAB

The prblem is shown below.How can I solve the problem.
Thank you.

Could you tell me how to install uqlab by myself instead of installing automatically?

I have solved the problem by trying twice times.The system is not very solid.

Hi @hezhanpeng, thanks for your interest in UQLab. I’m sorry that you’ve had that problem and I’m happy that you managed to solve your problem by yourself.

I don’t know why it didn’t work the first time (internet glitches?), but this kind of thing happens. Before posting a question though, perhaps it’s a good idea to try to solve your problem first and then mention that effort in your question if the problem persists. It seems, according to you, re-trying for the second time already solved the problem; you would have saved yourself some time asking and waiting for a reply in this forum. I’m sure people in this community would like to help you with your problem, but this forum is not a hotline channel, you should expect some time before anyone can get back to you.

1 Like

Dear @hezhanpeng,
thank you for using UQLab.
I noticed that you also opened another post earlier about registration issues:

From what I can tell, there is some type of issue that makes the connection to our servers difficult from your computer/location/region. I don’t know why, but as @xujia suggested the most likely explanation is that there is some form of firewall on your side that makes said connection either impossible or unstable. For what is worth, this is likely uncommon, because we have several hundreds of users from all over China and yet this is the first time we have this type of problems reported.

The installation error in this post falls in the same category: the zip file containing the installation files is not correctly downloaded (e.g. due to either a blocked connection or to an interruption during the download). Hence the installer gives you the “could not unpack the release file” error, because the downloaded file is incomplete. The second time you ran it, it probably downloaded the full file successfully (did you by any means turn on the proxy again?).

While I understand your frustration and the feeling that the system is not very solid, it is very likely a simple connectivity issue we have no control upon.

Finally, here are my recommendations on how to use these forums:

  • when you have a technical issue, either a bug or an issue with the registration process (as the two cases you posted here), please send a support request to uqlab@ethz.ch . A support ticket will be opened for you and you will be guided through the process of identifying the root of the issue and ways to deal with it directly by the Dev Team.
  • After the issue is solved, feel free to post your feedback/experience here on the UQWorld forums.

The forums themselves are intended as a place where to get support for your everyday usage of the software from other members of the UQLab users community. However, they do not substitute dedicated technical support for the registration, licensing, installation and operation of the software, as almost no members of the forums are actually involved with the IT backend.

In the meantime, I hope you will enjoy using UQLab and that it will serve your research well.

With best regards,