UQWorld

Archiving options in UQLink model

Hi all,

I’m happily using the UQLink functionality to interface with a non-Matlab computational model.
There are two small things that I noted:

If I set (according to the UQLink manual):

ModelOpts.Archiving.Zip = false ;

I get the warning:

Warning: The option provided "Zip" is of type logical, but the accepted types are: real, boolean. "Zip" is set to its default value:         1

I’m not sure about this; I followed the manual and don’t know another way to specify a boolean in Matlab.

A related comment: if I set

ModelOpts.Archiving.Action = ‘none’;

(as specified in the manual), I get the error

Reference to non-existent field 'Archive'.
Error in uq_initialize_uq_uqlink (line 301)
optArchiveAction.Value = OptDefault.Archive ;

Looking into the UQLab code it seems to me that I should specify ‘ignore’ instead of ‘none’. Please confirm if this is the case (and if so, maybe update the manual).

Best,

Benjamin

Hi @bsanderse,

Thank you very much for pointing these issues! They will be fixed in the next release of UQLab.

For now, if you really need to you avoid zipping the archive, you can directly fix the issue by changing L.330-331 of uq_initialize_uq_uqlink.m from:

[optArchiveZip, Options.Archiving] = uq_process_option(Options.Archiving, 'Zip',...
        OptDefault.Archiving.Zip, {'real','boolean'}) ;

to:

[optArchiveZip, Options.Archiving] = uq_process_option(Options.Archiving, 'Zip',...
        OptDefault.Archiving.Zip, 'logical');

You’ll be set using true or false as the value for that configuration option.

Let me know if this issue can be fixed this way.

And indeed, the correct way to specify the .Archiving.Action the way you want it (i.e., leave everything as-is) is to use ignore and not none. The manual will be updated accordingly.

Thanks a lot again!

Hi @damarginal ,

Thanks for the quick reply! I fixed the lines you mentioned and indeed, the code works fine now.

Best,

Benjamin